Payment security enhancement: browser obsolescence

November 26, 2015 - Announcements

Update February 2016: Our PSP has infact decided to delay this update for the production environment until 2017. You can therefore ignore the following annoucement with regard to the production environment however for the sandbox, the information is still relevant.

In order to reinforce payment transaction security and to respond to new PCI-DSS requirements, our PSP has decided to make changes to some internet protocols. In particular, the TLS 1.0 protocol will not be accepted anymore: payments with browsers using this protocol will therefore not be authorised.

Planning for update

  • Sandbox: 18/11/2015
  • Production: 24/02/2016

Browser – outdated version list :

  • Google Chrome: versions lower than 22
  • FireFox: versions lower than 27-22 (versions 23 to 25)
  • Internet Explorer: versions lower than 11 (for versions 8 to 10, a manual update is required [please see below])
  • Opera: versions lower than 14 to 16 (for versions 10 to 12.17 a manual update is required [please see below])
  • Apple Safari: versions lower than 7

In order to update your browser, you need to follow the below procedure:

  • Go to the Options part of your browser
  • Choose “Advanced settings”
  • Activate the options “TLS 1.1” and “TLS 1.2”:

alt

Live chat
No agent is free at the moment please send us a request through our contact form